The battery charge issue

--DSO203

Moderator: jpa

Re: The battery charge issue

by wundram » Thu Apr 14, 2011 11:09 am

After some soldering and heat shrinking I reversed the JST connector on my battery, and it works! Of course now the leads are too short, so I had to flip the battery over, and the door doesn't quite close right.

I don't know how Shiguru managed to plug the connector in backwards. On mine, I couldn't have put the plug in the wrong way without destroying the socket.

Here is a picture of my temporary fix. (I believe that Seeed will send me a replacement battery soon)
Attachments
battery.jpg
battery repair
battery.jpg (83.73 KiB) Viewed 4176 times
Pre-kindergarten
Pre-kindergarten
 
Posts: 4
Joined: Tue Apr 12, 2011 3:24 am

Re: The battery charge issue

by kotobuki » Thu Apr 14, 2011 2:57 pm

Hi,

This is an update to the previous post.

Now I can run the DSO Quad with the battery. I charged a few hours, but the battery gage on the screen still show the battery level as zero.

Does this mean the charger IC on my DSO Quad is broken, or not implemented yet?

Best,
Shigeru
Pre-kindergarten
Pre-kindergarten
 
Posts: 4
Joined: Mon Apr 11, 2011 11:50 am

Re: The battery charge issue

by pulsar » Sat Apr 16, 2011 7:40 pm

Looks like i've got the same issue as you all.
But mine won't even power on, i tried USB , Battery and USB + Battery with no luck…
Not even a sign of life :(

BTW you do not need to cut/solder the wire to switch them. With a small screwdriver/knife you can remove the wire from the plastic shell by lifting up the plastic part that is holding it.
Pre-kindergarten
Pre-kindergarten
 
Posts: 1
Joined: Sat Apr 16, 2011 7:37 pm

Re: The battery charge issue

by pmckenna » Sat Apr 23, 2011 4:30 am

I also was given a battery with the reverse polarity. I can now run the DSO Quad off of battery but the status light does not come on when connected to usb with the battery in. If I remove the battery and plug in the usb the status light does come on. Also the battery does not seem to be charging now.
Pre-kindergarten
Pre-kindergarten
 
Posts: 1
Joined: Sat Apr 23, 2011 4:27 am

Re: The battery charge issue

by PJE » Tue Apr 26, 2011 12:49 am

pmckenna wrote:I also was given a battery with the reverse polarity. I can now run the DSO Quad off of battery but the status light does not come on when connected to usb with the battery in. If I remove the battery and plug in the usb the status light does come on. Also the battery does not seem to be charging now.


To quote the immortal line from Monty Python - Luxury!

I only wish I had a battery with reverse polarity - Indeed any battery at all would be a step up from the empty space waiting for a battery...

Has anyone else received a Quad without the battery?

I do look on the bright side in that I did receive two probes, which some people seem to be missing.

Regards,

PJE
Pre-kindergarten
Pre-kindergarten
 
Posts: 2
Joined: Tue Apr 26, 2011 12:45 am

Re: The battery charge issue

by clothbot » Thu Apr 28, 2011 9:55 am

Technically, the battery polarity ok; red=positive, black=negative. I opened my DSO Quad up and the silk-screening on the board appears to be labeled properly, so it looks like it's the connector socket that's been soldered in the wrong way around.
Pre-kindergarten
Pre-kindergarten
 
Posts: 5
Joined: Sun Feb 13, 2011 4:26 am

Re: The battery charge issue

by clothbot » Thu Apr 28, 2011 10:20 am

If I have time tomorrow evening I'm going to (carefully) remove the LCD and resolder the socket in the correct orientation. Here's a photo I took illustrating the problem:

Image
DSO QUAD Battery Connector Bug - IMG_5916 by aplumb, on Flickr
Pre-kindergarten
Pre-kindergarten
 
Posts: 5
Joined: Sun Feb 13, 2011 4:26 am

Re: The battery charge issue

by lygra » Thu Apr 28, 2011 4:38 pm

kotobuki wrote:I'm not sure, but a simple protection circuit might be available inside the orange part of a battery. Thanks, Shigeru
I agree with jnd that there is little chance of internal battery protection. Multi-cell packs usually have battery protection, but single cell batteries seldom have such protection.
Elementary-3
Elementary-3
 
Posts: 318
Joined: Mon Nov 15, 2010 11:56 pm

Re: The battery charge issue

by thanh » Fri Apr 29, 2011 1:16 am

Just got my DSO Quad. I was excited and plug the battery in. I then smell some burn and feel some heat near the switch.
It didn't turn on. I searched Seed forum and found this thread. So I swapped the battery wires and the DSO nano can turn on with the battery, but it has no back light. If I use the USB port, the back light comes up. The battery voltage measured is 3.8v. Anyone seeing the back light after fixing this issue? And what's your battery voltage please?

Thanks

-Thanh

By the way, the battery does have a protection circuit on its output. It didn't suffer any damage when plugged in in reverse with USB cable connected to the DSO quad.
Pre-kindergarten
Pre-kindergarten
 
Posts: 6
Joined: Fri Apr 29, 2011 1:07 am

Re: The battery charge issue

by lygra » Fri Apr 29, 2011 1:33 am

clothbot wrote:If I have time tomorrow evening I'm going to (carefully) remove the LCD and resolder the socket in the correct orientation.
It might be more reasonable and safer to follow Pulsar's advice in this same thread and just reverse the pins in the battery connector. Then write an indelible felt tip pen warning in the battery compartment.
Elementary-3
Elementary-3
 
Posts: 318
Joined: Mon Nov 15, 2010 11:56 pm

PreviousNext

Who is online
Users browsing this forum: No registered users and 1 guest