Seeedstudio Forum

Electronics can be art.
It is currently Fri Apr 18, 2014 6:49 am




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: arduino bluetooth shield + amarino
PostPosted: Mon Jul 16, 2012 7:46 am 
Offline
Newbie
Newbie

Joined: Sun Jul 15, 2012 11:48 pm
Posts: 4
Honor: 0.00
Points: 4.00 Points
Hey!

I'm trying to use the amarino library to simplify the communication between android tablet and arduino, but i'm stuck already at the first steps.
i have this shield: http://www.seeedstudio.com/wiki/index.php?title=Bluetooth_Shield
and arduino UNO.

i tried uploading the sketch slave.pde to arduino and the device can be discovered by other bt devices and i was able to successfully pair it with my bt dongle on my pc.
the problem i see is that sometimes the green led starts to blink twice fast evey second and other times i see red and another led blinking (that is when the device can be found). and then i reset the device and again just green led...

the other thing is i can't see that device by using the amarino app on the samsung ace phone (android 2.2), but i can see other BT devices.

Any ideas?


Top
 Profile  
 
 Post subject: Re: arduino bluetooth shield + amarino
PostPosted: Tue Jul 17, 2012 9:54 am 
Offline
Corporal
Corporal

Joined: Mon Dec 05, 2011 6:12 am
Posts: 145
Honor: 0.00
Points: 145.00 Points
noob_rider wrote:
Hey!

I'm trying to use the amarino library to simplify the communication between android tablet and arduino, but i'm stuck already at the first steps.
i have this shield: http://www.seeedstudio.com/wiki/index.php?title=Bluetooth_Shield
and arduino UNO.

i tried uploading the sketch slave.pde to arduino and the device can be discovered by other bt devices and i was able to successfully pair it with my bt dongle on my pc.
the problem i see is that sometimes the green led starts to blink twice fast evey second and other times i see red and another led blinking (that is when the device can be found). and then i reset the device and again just green led...

the other thing is i can't see that device by using the amarino app on the samsung ace phone (android 2.2), but i can see other BT devices.

Any ideas?


Amarino accept only a special SPP ID. Seeedstudio bt modules send a different one and there are no AT commands to change this ID on the bt module.
If you check the log inside the amarino app you can see this (i think so)...


Led status:
Green led flashing 2 times/second = paired but disconnected
Green led flashing 1 times/second = paired and connected
Red and green led flashing = inquire

_________________
Best regards from Vienna/Austria
Rony


Top
 Profile  
 
 Post subject: Re: arduino bluetooth shield + amarino
PostPosted: Tue Jul 17, 2012 10:23 am 
Offline
Newbie
Newbie

Joined: Sun Jul 15, 2012 11:48 pm
Posts: 4
Honor: 0.00
Points: 4.00 Points
ahaaaaaa, thank you for telling me that... i've spent a few hours trying to pair the device by using amarino library and banging my head, because it worked with connecting to my PC.
is there a good tutorial on how to use this shield to send/recieve data with a custom android application?


Top
 Profile  
 
 Post subject: Re: arduino bluetooth shield + amarino
PostPosted: Thu Jul 19, 2012 9:25 pm 
Offline
Newbie
Newbie

Joined: Thu Jul 19, 2012 5:55 pm
Posts: 1
Honor: 0.00
Points: 1.00 Points
As said before is probably due to some android's bt broadcomm module bug that does not allow to find Class of device code 0x00.
There is a android application developed for that that you can find here: http://zornsoftware.codenature.info/blo ... hones.html . It worked for some people but must warn that it did no work on my LG optimus one with v2.3.3 android version but might work for others. Hopefully the developer will find a work arround....So far I got a useless shield in my hands for the use i intended to give.


Top
 Profile  
 
 Post subject: Re: arduino bluetooth shield + amarino
PostPosted: Fri Aug 31, 2012 12:50 pm 
Offline
Newbie
Newbie

Joined: Sun Jul 15, 2012 11:48 pm
Posts: 4
Honor: 0.00
Points: 4.00 Points
hey!
it seems that someone found a solution
http://arduino.cc/forum/index.php/topic,120113.msg908562.html#msg908562
if you give it a go please let me know if it worked for you or not :)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group  
Design By Poker Bandits